Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
\b(\d{1,3}(?: \d{3})+)(,\d{2})? {,2}[а-яА-Я,. ()]+\b(без|\d{2} копеек\)?, без)
"
gm
Input 1
1
New
3 322 559,32 руб. без НДС. 598 060,67 руб. НДС 3 920 619,99руб. с НДС. 5 026 813,65 руб. без НДС; 904 826,46 руб. НДС (18%); 5 931 640,11 руб. с НДС Лот 1. 4 837 251,02 руб. без НДС; 870 050,18 руб. НДС (18%); 5 707 956,20 руб. с НДС Лот 2. 75 290,87 руб. без НДС; 13 552,36 руб. НДС (18%); 88 843,23 руб. с НДС ИТОГО: 4 912 541,89 руб. без НДС 884 257,54 руб. НДС (18%); 5 796 799,43 руб. с НДС 1 307 856 (Один миллион триста семь тысяч восемьсот пятьдесят шесть) рублей 67 копеек, в т.ч. НДС. 1 214 490 (Один миллион двести четырнадцать тысяч четыреста девяносто) рублей 67 копеек, без учета НДС. 307 272,00 рублей (Триста семь тысяч двести семьдесят два рубля 00 копеек), включая НДС. 260 400,00 рублей (Двести шестьдесят тысяч четыреста рублей 00 копеек), без учета НДС.