re = /-?\d+(\.\d+)?/m
str = '4x²-8x+6 (or 4x^2-8x+6)
3x-8y=2
1.2+2x=5
23y-1=b
-3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end