use strict;
my $str = 'Thu Sep 07 2021 00:15:06 mailsv1 sshd[2605]: Failed password for invalid user itmadmin from 194.8.74.23 port 4692 ssh2
Thu Sep 07 2021 00:15:06 mailsv1 sshd[3759]: Failed password for nagios from 194.8.74.23 port 3769 ssh2';
my $regex = qr/\sfor\s(?:invalid\suser\s)?(?<Username>\w+)\s\w+\s(?<IP>[^\s]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}