#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(?([2-9])\)?([0-9]{2})?[-.*]?([2-9])\)?((?!11)[0-9]{2})?[-.*]?([0-9]{4})$"
Local $sString = "(2)33-233-2222" & @CRLF & _
"4805123848" & @CRLF & _
"4805218482" & @CRLF & _
"(2)33-212-2222" & @CRLF & _
"(2)33-221-2222" & @CRLF & _
"4809128327" & @CRLF & _
"4809418482" & @CRLF & _
"" & @CRLF & _
"(2)33-211-2222" & @CRLF & _
"4807119320" & @CRLF & _
"4805119439" & @CRLF & _
"4809114739"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")