import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?([2-9])\\)?([0-9]{2})?[-.*]?([2-9])\\)?((?!11)[0-9]{2})?[-.*]?([0-9]{4})$";
final String string = "(2)33-233-2222\n"
+ "4805123848\n"
+ "4805218482\n"
+ "(2)33-212-2222\n"
+ "(2)33-221-2222\n"
+ "4809128327\n"
+ "4809418482\n\n"
+ "(2)33-211-2222\n"
+ "4807119320\n"
+ "4805119439\n"
+ "4809114739";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}