import Foundation
let pattern = #"(?i)(?:\G(?!\A)|Catch(?:This|That|Anything)\s*\()[^()"]*\K""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Any text and "much" "more" of it. Don't replace quotes here
CatchThis( no quotes here, "any more text" , "and so on and so forth...")
catchthat("some other text" , "or less")
some text in "between"
CatchAnything ( "even more" , "and more", no quotes there, "wall of text")
more ("text"""") and quotes after...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)