$re = '/([a-zA-Z]+) \/(De|La|Le|Van|Von) /m';
$str = '0 @I@ INDI 1 NAME Anna /Von Hat/ 2 GIVN Anna 2 SURN Von Hat 1 BIRT 2 DATE 01 Jan 2000 2 PLAC Copenhagen, Copenhagen, Denmark';
$subst = "$1 $2 /";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;