use strict;
my $str = 'print "Anything goes here"
print "Anything"
print "Something goes here" ';
my $regex = qr/print\s+\"(.+)\"/mp;
my $subst = ' print("\\1")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";