$re = '/(?m)http(?:s?):\/\/.*?([^\.\/]+?\.[^\.]+?(?:\.\w{2})?)(?:\/|$)/u';
$str = 'http://careers.walmart.com/?codes=Linkedin&utm_source=Linkedin&utm_campaign=ALL&utm_medium=SocialOrganic&utm_term=AboutUs&utm_content=Branding
http://publix.jobs
https://jobs.gapinc.com/
https://forum.keyboardmaestro.com/t/simple-search-with-regex-question/15733/5
https://www.somedomain.co.uk/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);