using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!foo|bar).)+@.*$";
string input = @"abcfooxyz@domain.com
barabc@domain.com
barabc@domainfoo.com
abcxyz@domainfoo.com
pqrabc@domainbar.com
pqrabc@domain.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}