re = /^((?!foo|bar).)+@.*$/m
str = 'abcfooxyz@domain.com
barabc@domain.com
barabc@domainfoo.com
abcxyz@domainfoo.com
pqrabc@domainbar.com
pqrabc@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end