use strict;
my $str = 'www.company.com/pl_pl/company/contact/thank-you/dl/7011o000003pohk/msp/ttt/doc/whitepapers/pl_pl/whitepaper.pdf';
my $regex = qr`^.*[a-z]{2}_[a-z]{2}(/[^/]+\.\w+)$`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";