// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<(a\shref)="\w{4,5}:\/\/\w+.\w{2}">\w+(<\/a>)"#).unwrap();
let string = "<ul> <li> <a href=\"http://softuni.bg\">SoftUni</a></li></ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}