import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ ]?(?:1?\\d(?:[\\.\\,]\\d{1,2})?|20(?:[\\.\\,]0?0?)?)[ ]?$";
final String string = "sat\n"
+ "&é12dd\n"
+ "0\n"
+ "0.1 \n"
+ "0.12\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "4 \n"
+ " 5\n"
+ "5 \n"
+ "1.1 \n"
+ "2.24 \n"
+ "3.234 \n"
+ "5,1 \n"
+ "2,50 \n"
+ "3,535 \n"
+ "19\n"
+ "20\n"
+ "20.10\n"
+ "20.02\n"
+ "20.2\n"
+ "20.0 \n"
+ "20.00 \n"
+ "20.1 \n"
+ "20.0 \n"
+ "20,0\n"
+ "20.02\n"
+ "20,10\n"
+ "5.N \n"
+ "5,e";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}