#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\b(hyd)\W+"
Local $sString = "HYD. CYLINDER" & @CRLF & _
"HYD CYLINDER" & @CRLF & _
"HYD.CYLINDER" & @CRLF & _
"HYDRAULIC CYLINDER" & @CRLF & _
"CYLINDER,HYD." & @CRLF & _
"CYLINDER,HYDRAULIC" & @CRLF & _
"CYLINDER,HYD" & @CRLF & _
"CYLINDER, HYD." & @CRLF & _
"CYLINDER, HYDRAULIC" & @CRLF & _
"CYLINDER,HYD" & @CRLF & _
""
Local $sSubst = "HYDRAULIC "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)