$re = '/\b(hyd)(?:\s|$|[^\w])/i';
$str = 'HYD. CYLINDER
HYD CYLINDER
HYD.CYLINDER
HYDRAULIC CYLINDER
CYLINDER,HYD.
CYLINDER,HYDRAULIC
CYLINDER,HYD
CYLINDER, HYD.
CYLINDER, HYDRAULIC
CYLINDER,HYD
';
$subst = "HYDRAULIC";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;