# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(/sites(?:/[^/\"]+){2}/SitePages/[^/\"]+)\.aspx(?=\")"
test_str = "<div class=\"ms-wikicontent ms-rtestate-field\" style=\"padding-right: 10px\"><div class=\"ExternalClass8E56354CC4314DBA861E187B689F3A2B\"><table id=\"layoutsTable\" style=\"width:100%\"><tbody><tr style=\"vertical-align:top\"><td style=\"width:100%\"><div class=\"ms-rte-layoutszone-outer\" style=\"width:100%\"><div class=\"ms-rte-layoutszone-inner\" role=\"textbox\" aria-haspopup=\"true\" aria-autocomplete=\"both\" aria-multiline=\"true\"><a id=\"0::Home|Home\" class=\"ms-wikilink\" href=\"/sites/Team/Project/SitePages/Home.aspx\">Home</a> - <a id=\"1::Jenkins|Jenkins\" class=\"ms-wikilink\" href=\"/sites/Team/Project/SitePages/Jenkins.aspx\">Jenkins</a><h1 class=\"ms-rteElement-H1\">Jenkins Integration with Deployment Tools</h1>"
subst = "$1.html"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.