# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)/<em>\g<common>\g<uncommon><\/em>/gm;t' <<< "**part strong,** *part emphasized*"