#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)"
Local $sString = "**part strong,** *part emphasized*"
Local $sSubst = "<em>\g<common>\g<uncommon></em>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)