use strict;
my $str = '**part strong,** *part emphasized*';
my $regex = qr/((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)/mp;
my $subst = '<em>\\g<common>\\g<uncommon></em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";