import Foundation
let pattern = #"((?<=\s)\*(?P<common>[^\*]+?)\*(?=\s)|^\*(?P<uncommon>[^\*].*[^\*])\*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"**part strong,** *part emphasized*"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<em>\g<common>\g<uncommon></em>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)