import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\])<http(s)?:\\/\\/([^[\\]]+?)>(?!\\])";
final String string = "xxx\n"
+ "2. 使用`Jetbrains Mono`<https://github.com/JetBrains/JetBrainsMono>等宽字体进行代码高亮\n"
+ "2. 使用`Jetbrains https://github.com/JetBrains/JetBrainsMono等宽字体进行代码高亮\n"
+ "代码是开放的,自取:<https://github.com/ttys3/hugo-theme-terminal/tree/ttys3>\n"
+ "xxxx";
final String subst = "http\\$1://\\$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}