use strict;
my $str = 'http://www.domain.com/?paramZ=123456
https://www.domain.com/?param1=val1;param2=val2;param3=val3;paramZ=123456
http://www.domain.com/one/or/more?paramZ=123456;param1=val1;param2=val2;param3=val3
https://www.domain.com/one/or/more?param1=val1;paramZ=123456;param2=val2;param3=val3
http://www.domain.com/one/or/more?param1=val1;param2=val2;param3=val3';
my $regex = qr/^(http[s]?:\/\/www\.domain)(.*)(paramZ\=[\d]+)(.*)$/mp;
my $subst = '$1$2paramZ=987654$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";