package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'([^'\\]*(?:\\.[^'\\]*)*)'`)
var str = `[(u'apple',), (u'banana',)]
[(u'apple',), (u'banana',), (u'abc\'def',)]
\\'abc''def'
\\\'abc 'abc\\\\\'def'
|- CORRECT-|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}