re = /(?<!\\)(?:\\\\)*'([^'\\]*(?:\\.[^'\\]*)*)'/
str = '[(u\'apple\',), (u\'banana\',)]
[(u\'apple\',), (u\'banana\',), (u\'abc\\\'def\',)]
\\\\\'abc\'\'def\'
\\\\\\\'abc \'abc\\\\\\\\\\\'def\'
|- CORRECT-|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end