import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$";
final String string = "C:\\Deal\\v6\\.git\\logs\n"
+ "C:\\Deal\\v6\\\n"
+ "F:\\Deal\\v6\\compil.log\n"
+ "F:/Deal/v6/comp-il.log\n"
+ "F:/De al/v6/compil.log\n"
+ "F:/De al/v6/comp il.log\n"
+ "/c/Deal/v6\n"
+ "/c/Deal/v6\\\n"
+ "C:\\\n"
+ "/\n"
+ "/c\n"
+ "\\\\dwi3342\\Deal\\v6\\comp-il.log\n"
+ "//dwi3342/Deal/v6/compil.log\n"
+ "F:/Deal/../compil.log\n"
+ "GG:/Deal/v6/comp-il.log\n\n\n"
+ "^(.*\\/)([^\\/]*)$\n"
+ "((?:[^\\/]*\\/)*)(.*)\n"
+ "([\\/\\\\][^\\/\\\\]*$)\n\n"
+ "^(.*(?:\\/|\\\\))([^\\/\\\\]*)$\n"
+ "^((?:[^\\/\\\\]*\\/\\\\)*)(.*)$\n\n"
+ "^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?$\n"
+ "^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}