use strict;
my $str = 'C:\\Deal\\v6\\.git\\logs
C:\\Deal\\v6\\
F:\\Deal\\v6\\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\\
C:\\
/
/c
\\\\dwi3342\\Deal\\v6\\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\\/)([^\\/]*)$
((?:[^\\/]*\\/)*)(.*)
([\\/\\\\][^\\/\\\\]*$)
^(.*(?:\\/|\\\\))([^\\/\\\\]*)$
^((?:[^\\/\\\\]*\\/\\\\)*)(.*)$
^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?$
^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$
';
my $regex = qr/^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}