re = /^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$/m
str = 'C:\\Deal\\v6\\.git\\logs
C:\\Deal\\v6\\
F:\\Deal\\v6\\compil.log
F:/Deal/v6/comp-il.log
F:/De al/v6/compil.log
F:/De al/v6/comp il.log
/c/Deal/v6
/c/Deal/v6\\
C:\\
/
/c
\\\\dwi3342\\Deal\\v6\\comp-il.log
//dwi3342/Deal/v6/compil.log
F:/Deal/../compil.log
GG:/Deal/v6/comp-il.log
^(.*\\/)([^\\/]*)$
((?:[^\\/]*\\/)*)(.*)
([\\/\\\\][^\\/\\\\]*$)
^(.*(?:\\/|\\\\))([^\\/\\\\]*)$
^((?:[^\\/\\\\]*\\/\\\\)*)(.*)$
^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?$
^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end