#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[a-z]:)?(?:[\\\/][a-z0-9_. -]*)+$"
Local $sString = "C:\Deal\v6\.git\logs" & @CRLF & _
"C:\Deal\v6\" & @CRLF & _
"F:\Deal\v6\compil.log" & @CRLF & _
"F:/Deal/v6/comp-il.log" & @CRLF & _
"F:/De al/v6/compil.log" & @CRLF & _
"F:/De al/v6/comp il.log" & @CRLF & _
"/c/Deal/v6" & @CRLF & _
"/c/Deal/v6\" & @CRLF & _
"C:\" & @CRLF & _
"/" & @CRLF & _
"/c" & @CRLF & _
"\\dwi3342\Deal\v6\comp-il.log" & @CRLF & _
"//dwi3342/Deal/v6/compil.log" & @CRLF & _
"F:/Deal/../compil.log" & @CRLF & _
"GG:/Deal/v6/comp-il.log" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^(.*\/)([^\/]*)$" & @CRLF & _
"((?:[^\/]*\/)*)(.*)" & @CRLF & _
"([\/\\][^\/\\]*$)" & @CRLF & _
"" & @CRLF & _
"^(.*(?:\/|\\))([^\/\\]*)$" & @CRLF & _
"^((?:[^\/\\]*\/\\)*)(.*)$" & @CRLF & _
"" & @CRLF & _
"^(?:[a-zA-Z]:[\\\/]|[\\\/])(?:[a-zA-Z0-9_. -]+[\\\/])*(?:[a-zA-Z0-9_. -]+)?$" & @CRLF & _
"^(?:[a-zA-Z]:)?(?:[\\\/][a-zA-Z0-9_. -]*)+$" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")