import re
regex = re.compile(r"^(?:[a-z]:)?(?:[\\\/][a-z0-9_. -]*)+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("C:\\Deal\\v6\\.git\\logs\n"
"C:\\Deal\\v6\\\n"
"F:\\Deal\\v6\\compil.log\n"
"F:/Deal/v6/comp-il.log\n"
"F:/De al/v6/compil.log\n"
"F:/De al/v6/comp il.log\n"
"/c/Deal/v6\n"
"/c/Deal/v6\\\n"
"C:\\\n"
"/\n"
"/c\n"
"\\\\dwi3342\\Deal\\v6\\comp-il.log\n"
"//dwi3342/Deal/v6/compil.log\n"
"F:/Deal/../compil.log\n"
"GG:/Deal/v6/comp-il.log\n\n\n"
"^(.*\\/)([^\\/]*)$\n"
"((?:[^\\/]*\\/)*)(.*)\n"
"([\\/\\\\][^\\/\\\\]*$)\n\n"
"^(.*(?:\\/|\\\\))([^\\/\\\\]*)$\n"
"^((?:[^\\/\\\\]*\\/\\\\)*)(.*)$\n\n"
"^(?:[a-zA-Z]:[\\\\\\/]|[\\\\\\/])(?:[a-zA-Z0-9_. -]+[\\\\\\/])*(?:[a-zA-Z0-9_. -]+)?$\n"
"^(?:[a-zA-Z]:)?(?:[\\\\\\/][a-zA-Z0-9_. -]*)+$\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")