# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?(?:@heroImageURL\s*=\s*\"\"[^\"\"]+\"\".*?){1}@heroImageURL\s*=\s\"\")[^\"\"]+(?=\"\")"
test_str = (" IF @brandName == \"A\" THEN\n"
" set @heroImageURL = \"http://www.image.com/a9230239u230.jpg\"\n"
" set @productImageURL = \"http://www.image.com/A29200923.jpg\"\n"
" ELSEIF @brandName == \"B\" THEN\n"
" set @heroImageURL = \"http://www.image.com/b2389823u238.jpg\"\n"
" set @productImageURL = \"http://www.image.com/B22392029.jpg\"\n"
" ELSEIF @brandName == \"C\" THEN\n"
" set @heroImageURL = \"http://www.image.com/c23892389289.jpg\"\n"
" set @productImageURL = \"http://www.image.com/C49309934.jpg\"\n"
" ELSEIF @brandName == \"D\" THEN\n"
" set @heroImageURL = \"http://www.image.com/d23423892833.jpg\"\n"
" set @productImageURL = \"http://www.image.com/D09349409.jpg\"\n"
" ELSEIF @brandName == \"E\" THEN\n"
" set @heroImageURL = \"http://www.image.com/e22823889899.jpg\"\n"
" set @productImageURL = \"http://www.image.com/E22092309.jpg\"\n"
" ELSE\n"
" set @heroImageURL = \"http://www.image.com/e22823889899.jpg\"\n"
" set @productImageURL = \"http://www.image.com/E22092309.jpg\"\n"
" ENDIF")
subst = "$1http://www.google.com/1.jpg"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.