const regex = /^(\p{Han}+)(?:\P{Han}.*\1)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{Han}+)(?:\\P{Han}.*\\1)?$', 'gm')
const str = `测试1003##\$%#测试
测试1003##\$%#测
测试
`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);