$re = '/(\d+)_\d+(\.\w+)/m';
$str = '4711_001.doc';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;