#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^ *uses\r?\n *|\G(?!^))(\w+)(?:,\s*|;$)"
Local $sString = "unit ComandesVendes;" & @CRLF & _
"" & @CRLF & _
"interface" & @CRLF & _
"" & @CRLF & _
"uses" & @CRLF & _
" Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms," & @CRLF & _
" Dialogs, Manteniment;" & @CRLF & _
"" & @CRLF & _
"type" & @CRLF & _
" TFComandesVendes = class(TFManteniment,ActualitzacioFinestra)" & @CRLF & _
" QRCapsaleraNumero: TIntegerField;" & @CRLF & _
" QRCapsaleraData: TDateTimeField;" & @CRLF & _
" QRCapsaleraDataEntrega: TDateTimeField;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")