import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^ *uses\\r?\\n *|\\G(?!^))(\\w+)(?:,\\s*|;$)";
final String string = "unit ComandesVendes;\n\n"
+ "interface\n\n"
+ "uses\n"
+ " Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms,\n"
+ " Dialogs, Manteniment;\n\n"
+ "type\n"
+ " TFComandesVendes = class(TFManteniment,ActualitzacioFinestra)\n"
+ " QRCapsaleraNumero: TIntegerField;\n"
+ " QRCapsaleraData: TDateTimeField;\n"
+ " QRCapsaleraDataEntrega: TDateTimeField;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}