re = /(?:^ *uses\r?\n *|\G(?!^))(\w+)(?:,\s*|;$)/m
str = 'unit ComandesVendes;
interface
uses
Windows, Messages, SysUtils, Variants, Classes, Graphics, Controls, Forms,
Dialogs, Manteniment;
type
TFComandesVendes = class(TFManteniment,ActualitzacioFinestra)
QRCapsaleraNumero: TIntegerField;
QRCapsaleraData: TDateTimeField;
QRCapsaleraDataEntrega: TDateTimeField;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end