// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[a-zA-Z0-9]|\s\B){12}$").unwrap();
let string = "abC123def456
abc123dEf45
abc123def4
sd45f45FFFRd
abc123def45
abc123 ef456
123
sd45f45FFFR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}