using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/[A-Za-z0-9_.-]+\/[A-Za-z0-9_.-]+";
string input = @"/google.com/images/video
/msn.com/bing/chat
/bbc.com/video";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}