import re
regex = re.compile(r"\d{1,}\:[0-5][0-9]")
test_str = ("350:59\n"
"20:22\n"
"1:68\n"
"0:12\n"
"24:75")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")