re = /(?i)(:s|usa|what)/m
str = 'What is your least favorite thing about living in the USA?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end