# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*([^,\s]+)(?:,|$)/self.$1 = $1\n/gm;t' <<< "toto, titi, tata"