#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*([^,\s]+)(?:,|$)"
Local $sString = "toto, titi, tata"
Local $sSubst = "self.$1 = $1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)