use strict;
my $str = 'toto, titi, tata';
my $regex = qr/\s*([^,\s]+)(?:,|$)/mp;
my $subst = 'self.$1 = $1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";