import Foundation
let pattern = #"\s*([^,\s]+)(?:,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"toto, titi, tata"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"self.$1 = $1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)