$re = '/^([АВЕКМНОРСТУХавекмнорстух]){1}\d{3}\1{2}\d{2,3}$/m';
$str = 'A555BA77
А555Вb65
t333yx179
а001аа177
АВЕКМНОРСТУХ
ABEKMHOPCTYX
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);