$re = '/.*(Dock_1:)\s*\[(.*)\].*/m';
$str = 'Dock_1: [UNUSED]
Dock_2: [UNUSED]
Dock_3: [UNUSED]
#This must be typed in the display block that detect the dock point is used
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [USED]
#This must be typed in the display block that detect the dock point is unused
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [UNUSED]';
$subst = "Dock_1: [USED]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;