package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9-_]+)_$`)
var str = `start_
some_anchor_
another-anchor_
\`Document Title\`_
Document Title_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}