const regex = /ATS-[0-9]{7}/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ATS-[0-9]{7}', 'mig')
const str = `ATS-0123456
ats-0123456
Ats-2333333
aTs-2525252`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}