#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\[\s*\])[a-zA-Z0-9_\-\[\] ]*$"
Local $sString = "Your message here" & @CRLF & _
"Your [text] message here" & @CRLF & _
"your_text_message [text]" & @CRLF & _
"Your [] message here" & @CRLF & _
"[] message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")