using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(?<baseUrl>\/([^\/]+\/)+)(?<guid>[^\""]+)\""";
string input = @"""/dsa/api/playercommands/a6ada68b-7a72-4f38-b752-d99f7efd4cb8""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}